0 850 650 0 500|teknik@wi.com.tr

CRS Switch için tüm portları hızlıca masterport tanımlama ( Script Tabanlı )

Merhaba ;

CRS Switchlerde port sayısı 24 olunca ve sürekli olarak tek tek portlara girip masterport-x olarak tanımlamak zaman aldığı için ve genelde bu konuda yorulduğumuz için basit bir script oluşturduk .bunu kullanabilirsiniz.

Bu script’i terminal ‘e kopyalayıp yapıştırabilirsiniz ve komut satırı ile çalıştırabilirsiniz.

Otomatik port oluşturma script’i aşağıdaki gibi yer almaktadır . script ‘i terminal oluşturup ekleyebilirsiniz.

 
/system script
add name="Master Port Tanımlama" owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source="#\r\
    \n#\r\
    \n# Master Port Oluşturma için aşağıdaki değişkenleri belirlememiz gerekmektedir. \r\
    \n# Port tanımı yaparken  Ethernet yada SFP olarak belirleyiniz \r\
    \n# Port Aralığını BasPort ile Bitport değişkenlerine tanımlamalısınız .\r\
    \n:global MasterPort \"ether24\"\r\
    \n:global PortTipi \"ether\"\r\
    \n:global BasPort \"1\"\r\
    \n:global BitPort \"9\"\r\
    \n:for i from=\$BasPort to=\$BitPort do={\r\
    \n/interface ethernet set (\$PortTipi . \$i) master-port=\$MasterPort\r\
    \n}"

Eğer mevcut tanımları temizlemek isterseniz aşağıdaki komut işinizi görecektir.

/system script
add name="MasterPortları Temizle" owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source=\
    "/interface ethernet\r\
    \nset [find] master=none"

komutları kullanmak için terminal ‘de

/system script run "Master Port Tanımlama"  şeklinde çalıştırabilirsiniz. 
 

Winbox arayüzünde aynı şekilde /system – Script menüsü içerisinde tanımlanmış scriptleri görüntüleyebilir ve run ‘a tıklayıp çalıştırabilirsiniz.

By | 2017-04-11T08:34:22+00:00 11 Nisan, 2017|CRS Switch için tüm portları hızlıca masterport tanımlama ( Script Tabanlı ) için yorumlar kapalı

About the Author: