0 850 650 0 500|teknik@wi.com.tr

Bandwith test ve RouterOS script ile Telegram’a gönderme

Senaryo :
2 ayri mikrotik cihazımız var ve bu cihazların aralarındaki bandwith değerlerinin raporlanmasını istiyoruz .
2 ayrı ubnt yada farklı bir link’de olabilir önemli olan mikrotik cihazlarının bu linklerin arkasında olması ve bu ip route’larının üzerindeki geçen trafiğin aktarılmasıdır.

önce telegram ‘dan bir api kullanıcısı oluşturuyoruz.
https://core.telegram.org/api/obtaining_api_id
oluşan api ID bilgilerini aşağıdaki alana ekliyoruz.

telebotID ve TeleChatID oluşturma ile ilgili makalemize
http://bilgi.wi.com.tr/telegram-bot-id-chat-id-olusturma/ ulaşabilirsiniz.

:local MESAJ "X LINKI ISTASYON TX-HIZI"  # size ulaşmasını istediğiniz mesaj 
:local IP "192.10.192.2"   # hedef bw test server ip 
:local USER "admin" # hedef bw test server mikrotik kullanıcı adı  
:local PASS "123456"  # hedef bw test server mikrotik şifresi 
:local SANIYE "20s"  # test süresi saniye olarak 
:local CHATID "-1231233"  # telegram api chat id 
:local APIID "xxxx:xxxxx"  # telegram api  id 

:local txta
:local txtaA
:local txtaB
:local txtaC

/tool bandwidth-test $IP protocol=tcp direction=transmit duration=$SANIYE user=$USER password=$PASS do={

:set txtaA ($"tx-total-average" / 1000)
:set txtaB ($txtaA / 1000 * 1000)
:set txtaC ($txtaA - $txtaB)
:set txtaB ($txtaB / 1000)
:set txta "$txtaB.$txtaC"
}

/tool fetch keep-result=no url="https://api.telegram.org/$APIID/sendMessage\?chat_id=$chatid&text=$MESAJ  $txta Mbps  "

artık bu link üzerindeki bw kullanım raporlarını anlık olarak telegram üzerinden takip edebilirsiniz.

kaynak : YAKANET ELK.HAB.HİZ.LTD.ŞTİ. / Muhammet bey .
Açıklama & Düzenleme : Wi.com.tr

By | 2017-05-30T10:11:21+00:00 29 Mayıs, 2017|Bandwith test ve RouterOS script ile Telegram’a gönderme için yorumlar kapalı

About the Author: