0 850 650 0 500|teknik@wi.com.tr

Mikrotik Hotspot Kullanıcılarını Zamanlı olarak Pasif et [Mikrotik Scripting]

Mikrotik ‘ın en yaygın olarak kullanıldığı alanlardan birisi’de hotspot kullanımıdır.
bazı durumlarda hotspot kullanıcılarının belirli zamanlarda otomatik kapatılması ,yada otomatik silinmesi ihtiyacı doğabiliyor.
bu gibi durumlar için aşağıda örneklerle anlatım gerçekleştirelim.
öncelikli olarak mikrotik cihazımızın tarih / saat bilgisinin güncel ve sürekli güncelliğinden emin olunması gerekmektedir. bu çalışacak kuralın zamanlanmasında önemli rol oynamaktadır.

Önemli :SNTP servisini kurmaniz için gerekli makaleyi mutlaka inceleyin.

1 — Mikrotik Hotspot kullanıcıları gece 00:00 ile sabah 09:00 arasında kullanıcılar pasif olsun ve kullanıcı girişi gerçekleşmesin.

Kullanıcıların 23:59:59 ‘da pasif edilmesi için gerekli script dizisi

/system scheduler
add interval=1d start-date=dec/08/2017 start-time=23:59:59 name=Hotspot_Kullanici_Kapat on-event="/ip hotspot user \n [:for i from=1 to= ([:len [find]]-1) do={ set disabled=yes  $i }]" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon 

Kullanıcıların 09:00:00 ‘da aktif edilmesi için gerekli script dizisi

/system scheduler
add interval=1d start-date=dec/08/2017 start-time=09:00:00 name=Hotspot_Kullanici_Ac on-event="/ip hotspot user\n [:for i from=1 to= ([:len [find]]-1) do={ set disabled=no  $i }]" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon 

Buradaki start-time bilgilerini istediğiniz gibi ayarlayarak kullanıcıların pasif yada aktif edilme zamanlarını belirleyebilirsiniz.

2 — Mikrotik Hotspot kullanıcılarının belirli bir saat’de komple temizlenmesini istiyorum ,her kayıtlı kullanıcıyı tek tek secip silmek istemiyorum sorusu için aşağıdaki script’i kullanabilirsiniz.

/system scheduler
add interval=1d start-date=dec/08/2017 start-time=04:00:00 name=Hotspot_Kullanici_temizle on-event="/ip hotspot user \n  [:for i from=1 to= ([:len [find]]-1) do={ remove $i }]" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon 

3 — Mikrotik Hotspot Cookies ‘de kayıtlı kullanıcıların temizlenmesi ( Profil’de timeout tanımlıysa gerekmez )

/system scheduler
add interval=1d start-date=dec/08/2017 start-time=04:00:00 name=Hotspot_Cookies_Temizle on-event="/ip hotspot cookies \n  [:for i from=0 to= [:len [find]] do={ remove $i }]" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon 

Not :Bu makale bilgi vermek amaçlı hazırlanmıştır. Cihazınızda yada ayarlarda oluşabilecek problemlerden sorumlu değiliz.

By | 2017-12-09T18:23:55+00:00 9 Aralık, 2017|Mikrotik Hotspot Kullanıcılarını Zamanlı olarak Pasif et [Mikrotik Scripting] için yorumlar kapalı

About the Author: