0 850 650 0 500|teknik@wi.com.tr

Mikrotik ile Ping Watchdog – Sms Gönderimi

Senaryo :
Merkezi bir noktada mikrotik Router ‘ımız var ve bu mikrotik router’ımız network üzerindeki belirli AP / Server / Swich noktalarına Ping gönderecek ve eğer ping ‘den belirli bir sürede cevap alamaz ise X cihazına erişim kesildi , yada tekrar cevap alabilirse X cihazı tekrar aktif oldu şeklinde bir sms göndersin ..

Yapı için önelikli olarak bir sms servis sağlayıcı tercih ediyoruz.
Hedef ip adresimiz 172.16.80.1 buna göre hedef ip adreslerinizi aşağıdaki text ‘de değiştirin..

/tool netwatch
add disabled=yes down-script="log warning " 172.16.80.1 -PING ATAMIYORUM 5 DK bekliyorum açılmazsa sms gönderecem " ; /system script run PINGYOK-172.16.80.1" host=\
    172.16.80.1 interval=60s up-script="log warning " 172.16.80.1 -PING GELDI 1 dk bekliyorum gitmezse geldi diye sms gönderecem " ; /system script run PINGGELDI-172.16.80.1"

Bu işlem ile birlikte eğer ip 60 sn ‘de bir ping gönderecek ve eğer ping down olursa down script , up olursa up script ‘i çalıştırıyor olacak
up ve down scriptleri

/system script
add name=PINGYOK-172.16.80.1 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source=":if ([/ping 172.16.80.1 interval=5 count=60] =0) do={\r\
    \nlog warning \"PING atam\FDom\";local str \"http://api.plusmesaj.com/v1/send-sms/get/\?username=SMSKULADI&password=SMSSIFRE&text=PING_YOK_172_16_80_1&receipents=ALICITELEFON&&sender=GONDERICI\";/tool fetch url=\$str mode=http;log info \$str;\r\
    \n}"
add name=PINGGELDI-172.16.80.1 owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive source=":if ([/ping 172.16.80.1 interval=5 count=4] =1) do={\r\
    \nlog warning \"PING Atabiliyorum \";\r\
    \nlocal str \"http://api.plusmesaj.com/v1/send-sms/get/\?username=SMSKULADI&password=SMSSIFRE&text=PING_GELDI_172_16_80_1&receipents=ALICITELEFON&&sender=GONDERICI\";\r\
    \n/tool fetch url=\$str mode=http;\r\
    \nlog info \$str;\r\
    \n}"

SMS operatörü olarak PlusMesaj.com ‘un altapısına göre hazırlanmıştır.
dilediğiniz platform ‘a hızlıca url yolunu değiştirerek adapte edebilirsiniz.

Kaynak göstermek kaydı ile web sitenizde paylaşabilirsiniz.

Saygılar.

By | 2016-11-21T13:25:48+00:00 6 Ocak, 2016|0 Comments

About the Author:

Leave A Comment