0 850 650 0 500|teknik@wi.com.tr

Mikrotik NTH Load Balance ile 3 WAN

Mikrotiğiniz’de 3 adet modem bağlı ve bu modemleri tek modem gibi kullanmak ağınızdaki kullanıcılara eşit kullanıcılara dağıtmak istiyorsunuz.

bu aşamada  modemlere sırası ile

Modem1 : IP :  192.168.1.1    Subnet : 255.255.255.252

Modem2 : IP : 192.168.2.1  Subnet :255.255.255.252

Modem3 : IP : 192.168.3.1  Subnet : 255.255.255.252

olarak tanımlıyoruz . eğer modemlerinizden içeri doğru ip yönlendirmeniz varsa ( kamera, web vs )

bu durumda her modemin içerisinde DMZ  tanımları yapılmış olmalıdır.

DMZ ayarları aşağıdaki şeklide tanımlanmalıdır

Modem 1 :  192.168.1.2

Modem 2 : 192.168.2.2

Modem 3 . 192.168.3.2

Daha sonra mikrotiğimizde aşağıdaki kural zincirini ekliyoruz.

 

/ip address add address=192.168.1.2/24 interface=ether1

/ip address add address=192.168.2.2/24 interface=ether2

/ip address add address=192.168.3.2/24 interface=ether3

/ip address add address=192.168.10.1/24 interface=ether5

 

/ip firewall address-list add address=192.168.10.0/24 list=local

 

/ip route add gateway=192.168.1.1

/ip route add gateway=192.168.1.1 routing-mark=BIR

/ip route add gateway=192.168.2.1 routing-mark=IKI

/ip route add gateway=192.168.3.1 routing-mark=UC

 

/ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade

/ip firewall nat add chain=srcnat out-interface=ether2 action=masquerade

/ip firewall nat add chain=srcnat out-interface=ether3 action=masquerade

 

/ip firewall mangle add action=add-src-to-address-list address-list=BIRINCI address-list-timeout=0s chain=”ISARETLENMEYEN” disabled=no nth=3,1

/ip firewall mangle add action=add-src-to-address-list address-list=IKINCI address-list-timeout=0s chain=”ISARETLENMEYEN” disabled=no nth=3,2

/ip firewall mangle add action=add-src-to-address-list address-list=UCUNCU address-list-timeout=0s chain=”ISARETLENMEYEN” disabled=no nth=3,3

/ip firewall mangle add action=add-src-to-address-list address-list=GORULEN address-list-timeout=0s chain=”ISARETLENMEYEN” disabled=no

/ip firewall mangle add action=jump chain=”ISARETLENMEYEN” disabled=no jump-target=”ISARETLE”

 

/ip firewall mangle add action=mark-connection chain=”ISARETLE” disabled=no new-connection-mark=BIRINCI_CONN passthrough=yes src-address-list=BIRINCI

/ip firewall mangle add action=mark-connection chain=”ISARETLE” disabled=no new-connection-mark=IKINCI_CONN passthrough=yes src-address-list=IKINCI

/ip firewall mangle add action=mark-connection chain=”ISARETLE” disabled=no new-connection-mark=UCUNCU_CONN passthrough=yes src-address-list=UCUNCU

/ip firewall mangle add action=mark-routing chain=”ISARETLE” connection-mark=BIRINCI_CONN disabled=no new-routing-mark=BIR passthrough=no

/ip firewall mangle add action=mark-routing chain=”ISARETLE” connection-mark=IKINCI_CONN disabled=no new-routing-mark=IKI passthrough=no

/ip firewall mangle add action=mark-routing chain=”ISARETLE” connection-mark=UCUNCU_CONN disabled=no new-routing-mark=UC passthrough=no

/ip firewall mangle add action=mark-routing chain=prerouting connection-mark=BIRINCI_CONN disabled=no new-routing-mark=BIR passthrough=no src-address-list=BIRINCI

/ip firewall mangle add action=mark-routing chain=prerouting connection-mark=IKINCI_CONN disabled=no new-routing-mark=IKI passthrough=no src-address-list=IKINCI

/ip firewall mangle add action=mark-routing chain=prerouting connection-mark=UCUNCU_CONN disabled=no new-routing-mark=UC passthrough=no src-address-list=UCUNCU

/ip firewall mangle add action=jump chain=prerouting connection-state=new disabled=no jump-target=”ISARETLE” src-address-list=local

/ip firewall mangle add action=jump chain=prerouting connection-state=new disabled=no jump-target=”ISARETLENMEYEN” src-address-list=local

 

bu komutları uyguladıktan sonra artık 5 Nci port ‘a bilgisayarınızı bağladığınızda ( DNS ve DHCP / IP ) yapılandırmalarınızın olduğunu varsayıyorum .

ether5 portunun ip adresi : 192.168.10.1 olacaktır ve iç network ‘de tanımladığınız tüm ip tanımlı bilgisayarlar internete 3 modem ‘den bağlantı sırasına göre sırayla erişiyor olacaklardır.

aşağıdaki kuralı çoğaltalar networkümüzdeki diğer erişilebilir ip adreslerini ‘de bu kurala dahil edebiliriz. tabi interface ‘lerden birisinde tanımlı olmalı ve aktif çalışır durumda olmalıdır .

/ip firewall address-list add address=192.168.10.0/24 list=local

DHCP yapılandırma ile ilgili dökümanlarımızı yakın zamanda sitemizde yayınlıyor olacağız .

Saygılarımızla.

 

By | 2016-11-15T09:02:26+00:00 8 Nisan, 2014|8 Comments

About the Author:

8 Comments

  1. Sercan 2 Ekim 2014 at 21:16

    Merhaba;

    NTH üzerine vermiş olduğunuz bilgiler güzel. Fakat yapmış olduğunuz tanımlamaların neden yapıldığı ve ne ile ilgili olduğu konusunda bilgi verilseydi daha kalıcı ve faydalı olacağını düşünüyorum. Mesela şu nedenden şu şekilde kuralı eklıyoruz ki şöyle olsun diyebilmeniz, bizlerinde şundan dolayı böyle yaptık anlaşılmıştır dememizi sağlayacaktır.

    • admin 15 Ekim 2014 at 20:19

      Merhaba sercan bey ;
      eleştiriniz için teşekkür ederiz ; söylediklerinizde sonuna kadar haklısınız . lakin uygulanan kuralların nedenlerini açıklamaya başlarsak siz yazıyı okumaktan sıkılırsınız. bizde yazmakla bitiremeyiz.
      temel olarak yapılan kural zinciri sonuca ulaştırmaktadır. bu talebinizi dikkate alıyoruz. ilerleyen günlerde bu konu ile alakalı detaylandırmaya çalışırız.
      saygılar .

  2. Emrah 6 Ocak 2015 at 03:21

    yazı gayet açıklayıcı olmuş. sercan arkadaşımızın fikrine katılmıyorum.buradaki kuralların ne işe yaradığını bilmeyen yada bu isimlerin ne anlama geldiğini bilmeyen zaten açıklayıcı yazılsa bile anlaşılmaz.yani network için en alt terimlere ve bilgilere sahip olmadıkça birşey anlaşılmaz

    • Loadbalance konusu derin bir konu bu yaptığımız bizim route yönlendirme, tüm load balance yapılarında olduğu gibi kaynağı hedefe yönlendirecek metodlar. parametlerelerin anlamlarını tek tek açıklamak uzun olur ama anlamadığınız varsa yazarsanız yardımcı olmaya çalışalım.

  3. Deniz 27 Ağustos 2015 at 12:24

    Benim elimde Routerboard 1200 var 10 ethernet girişi var Buna 8 tane adsl load balance yapmak istiyorum. yardımcı olabilirmisiniz.

    • admin 15 Eylül 2015 at 19:35

      Merhaba ;
      NTH ile 8 port’a kadar load balance yapılabilir .bir diğer yapı ile PCC ile 32 modeme kadar load balance yapılabilir. iletişimden görüşerek işlem için hizmet bedeli konusunda dönüş alabilirsiniz.
      mevcut örnekler üzerinden işlem gerçekleştiremiyorsanız tarafımızdan ücreti karşılığında kurulum desteği alabilirsiniz.
      tşk.

  4. Tunahan 4 Kasım 2015 at 23:21

    Benimde elimde routerboard 1200 HX a var asıl sormak istediğim 8 adet adsl hattını birleştirip load balans yapmak istiyoruz. Otelde Hotspot için kullanaçağım.
    1. En iyi yöntem hangisidir.
    2. Aynı anda 500 kişi internete çıkıyor özellikle akşam saatlerinde her birisine 512 k upload 2mb download veriyorum. Her adsl modemimde 800k upload 8mb download mevcut. Burda load balans her client i bir diğerine sıra ile atıyor sanırım. Ama kullanılmadığı da bazı modemler atıl kalıyor. Yoğunluğa göre bir dağıtım yapsak nasıl olur. Elimde 4 modem mevcuttu sıkıntı oluyor diye 8 e çıkaracağım. Ama yüke göre bir dengeli load balans i nasıl yaparız. Farlı yöntemler biyerde hepsini birleştirip 8×8 64mb download 8 mb upload vb yapıp direk ordan interneti dağıtsam.
    3. Bide herkesin girdiği yerler için bir başkası girerken internet trafiği yorma mak için ne yapılabilir
    4. Facebook ve youtube filim izlemeyi kapatmayı.
    5. İnternet üzerinden void skype vb.. görüşmelerini nasıl kapatabilirim.
    Saygılarımla.

    • admin 11 Kasım 2015 at 22:14

      Merhaba ;
      Belirttiğiniz işlem için PCC load balance yapılandırılabilir;
      söylediğiniz tüm adımlar rahatlıkla karşılanabilir
      herkezin girdiği sayfaları cachelemek için Proxy server kullanabilirsiniz. ( Squid )
      ip engellemesi ile Youtube ,Facebook kapatılabilir .

Leave A Comment