0 850 650 0 500|teknik@wi.com.tr

Mikrotik PCC Metoduyla Load Balancing – Mikrotik Dual WAN

Mikrotik PCC metodu ile load balancing yük dengeleme şeklinde çalışır. Birleştirilmiş hattın kapasitesi hız testlerinde görüntülenemeyebilir. PCC metodu ile load balancing hat miktarı aşıldıktan sonra 2. hattın devreye girmesi şeklinde çalışır. Bu yöntemde band genişliği en adil şekilde dağıtılır. Fakat HTTPS (SSL) ile çalışan web sitelerinde ve bankacılık işlemlerinde problemler yaşanabilir. Sürekli ip değişmesi kopmalara neden olabilir.
Bu anlatımda ki yazıları terminal aracılığıyla direk mikrotiğinize kopyalabilirsiniz. Yapmanız gereken sadece interface isimlerini değiştirmek.

 

network

DSL MODEM IPLERI ve INTERFACE İSİMLERİ

DSL MODEM 1 = 192.168.20.1 WAN1
DSL MODEM 2 = 192.168.30.1 WAN2
LOKAL ADRES = 192.168.0.1 ANALINK

/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ANALINK
add address=192.168.20.2/24 network=192.168.20.0 broadcast=192.168.20.255 interface=WAN1
add address=192.168.30.2/24 network=192.168.30.0 broadcast=192.168.30.255 interface=WAN2

/ip dns
set allow-remote-requests=yes servers=195.175.39.39,195.175.39.40

/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn

add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2

add chain=prerouting dst-address=192.168.20.0/24 action=accept in-interface=ANALINK
add chain=prerouting dst-address=192.168.30.0/24 action=accept in-interface=ANALINK

add chain=prerouting dst-address-type=!local in-interface=ANALINK per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=ANALINK per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

add chain=prerouting connection-mark=WAN1_conn in-interface=ANALINK action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface= ANALINK action=mark-routing new-routing-mark=to_WAN2

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.20.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.30.1 routing-mark=to_WAN2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.20.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.30.1 distance=2 check-gateway=ping

/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

Pcc load balanc

Test yaptığımızda sonucumuz.

test2

By | 2016-11-12T12:37:16+00:00 23 Kasım, 2013|6 Comments

About the Author:

6 Comments

  1. Sezgin 14 Nisan 2014 at 11:01

    Ramazan Bey

    Yapmis oldugunuz calisma icin tsk ederim. Fakat speedtest sonuclari cok olumlu olurlar sitelere giris cok yavasliyor ozellikle https lere, bunun bir cozumu varmi, tesekkurler.

    • admin 12 Mayıs 2014 at 21:34

      Merhaba ;
      Https isteklerini bu loadbalance tanımlarının dışında tutup https isteklerini boş olan bir modeminize Firewall/ mangle kuralı ile işaretleyip yine routing mark yaparak tanımlı az kullanılan bir modeme yönlendirebilirsiniz.
      bir alternatif çözüm tabiki. yavaşlama durumu https isteklerinde sürekli aynı ip ‘den handshake yapmak istediği için bu sıkıntı olabilmekte .. tabi bazı SSL firmalarının istekleri için geçerlidir.

  2. MrPerFormance 1 Haziran 2015 at 09:21

    Merhabalar;

    Yazınız için teşekkür ederim. Ellerinize sağlık. Bir konuda yardımınıza ihtiyacım var. Sizinde bildiğiniz gibi bazı bankaların online işlemleri ve bazı online oyunlar multiwan üzerinde sorun çıkarmaktalar. Bu gibi durumlarda bu istekleri tek hat üzerine yönlendirmemiz gerekebiliyor. Bu durumda firewall üzerinde bir rol tanımlamamız gerekiyor. Bu konuda yardımınıza ihtiyacım var. Yardımcı olabilirseniz sevinirim.

    İyi Çalışmalar.

    • admin 1 Haziran 2015 at 14:02

      Selamlar ;
      bu gibi konularda tüm kuralların üst tarafında yeni bir kural oluşturabilirsiniz.

      öncelikle hangi ip adresleri için (x,y,z) ip adresleri için tek WAN ‘dan çıkış yapmasını istiyoruz. ve mesela to_OYUN_WAN diye bir adres list ismi olsun.
      bunun için bir adres list oluşturup o alanda ip adreslerini tanımlıyoruz.

      /ip firewall address list ‘e girip bir adres listesi içerisinde ip tanımlarını yapıyoruz .
      daha sonra
      ip firewall mangle sekmesinde bir mangle ekliyoruz ( bunu listenin en üstüne taşıyacağız unutmayın )
      mangle chain olarak prerouting seçiyoruz ve adres list olarak dst-address list ‘e tıklayıp daha önce oluşturduğumuz adres listesini seçeneklerden seçiyoruz.
      daha sonra action ‘a girip mark connection diye işaretleyip connection name olarak CONN_TO_OYUN_WAN ismini verelim ve kaydedelim ( Passtrougth) işaretli olacak.

      tekrar yeni bir mangle daha ekleyelim. ve bu mangle ‘de yine prerouting seçip connection_mark seçeneğinde ( CONN_TO_OYUN_WAN ) ı işaretleyelim.
      Action a geçip Mark Routing ‘i tanımlayalım ve ismine TO_Oyun_WAN ismini verelim . (Passtrougth seçili olmayacak )
      son olarak
      /ip routing ‘e girip 0.0.0.0/0 için gw olarak default çıkmasını istediğimiz GW ‘yi tanımlıyoruz ve alt sekmede yer alan Routing Mark ‘a tıklayıp ( TO_Oyun_WAN ) ‘ı listeden seçiyoruz.

      artık adres listesine eklediğimiz x.y.z ip adreslerine giden tüm istekler /ip routing ‘de belirleyeceğimiz GW ‘den çıkacaktır.

      saygılar.

  3. coskun 25 Kasım 2016 at 17:35

    load balance yapiyoruz. fakat Hotspot tabinladigimiz kullanicilari dogrulayip wan dan internete cikamiyoruz. hotspotu durdurdugumuzda internete cikis yapioyoruz

    • admin 9 Aralık 2016 at 06:58

      bunun birçok nedeni olabilir .sıfırlayıp tekrar yapılandırmayı deneyebilirsiniz , yada erişimin gerçekleşmediği andaki logları paylaşmanızı rica edeceğim.

Leave A Comment