0 850 650 0 500|teknik@wi.com.tr

Mikrotik Torrent Engelleme ( Layer7 Kuralı ile )

Tüm Firewall , GW ürünlerinde torrent engelleme başlıca bir sorundur .
bu sorunu mikrotik’de en aza indirgeme yöntemi ise RouterOS ‘un nimetlerinden olan LAYER7 protokolünde kural oluşturmaktır.

bu işlem için aşağıda hızlı uygulama dökümü yer almaktadır.

SSL tabanlı çalışan torrent ve benzeri sıkıntılı uygulama parçaları işin sürecini zorlaştırabilmektedir.
bunun için ayrıca DNS bloklama teknikleri ile çözümler üretilebilir.


/ip firewall layer7-protocol
add name=torrentsites regexp="^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|torrentz|vertor|h33t|btscene|bitunity|bittoxic|thunderbytes|entertane|zoozle|vcdq|bitnova|bitsoup|meganova|fulldls|btbot|flixflux|seedpeer|fenopy|gpirate|commonbits).*\$"
 
/ip firewall filter
add chain=forward src-address=192.168.1.0/24 layer7-protocol=torrentsites action=drop comment=torrentsites
add chain=forward src-address=192.168.1.0/24 protocol=17 dst-port=53 layer7-protocol=torrentsites action=drop comment=dropDNS
add chain=forward src-address=192.168.1.0/24 content=torrent action=drop comment=keyword_drop
add chain=forward src-address=192.168.1.0/24 content=tracker action=drop comment=trackers_drop
add chain=forward src-address=192.168.1.0/24 content=getpeers action=drop comment=get_peers_drop
add chain=forward src-address=192.168.1.0/24 content=info_hash action=drop comment=info_hash_drop
add chain=forward src-address=192.168.1.0/24 content=announce_peers action=drop comment=announce_peers_drop
 
# Varsayılan Rule 'ın aktif olması için aşağıdaki kuralıda devreye almanızda fayda var ( çoğu zaman başarılı olmayabiliyor ) 
 
add chain=forward src-address=192.168.1.0/24 p2p=all-p2p action=drop comment=p2p_drop

By | 2016-11-15T08:56:13+00:00 2 Ekim, 2014|0 Comments

About the Author:

Leave A Comment