0 850 650 0 500|teknik@wi.com.tr

Mikrotik WAN ip değişirse telegram ile haber gelsin.

Mikrotik ‘deki wan interface’ler ( DSL , local ,herhangi bir dhcp yada vpn client olabilir . ip bilgisi değiştiğinde bu bilginin tarafınıza ulaşmasını istiyorsanız telegram yada sms ile bu bilginin tarafınıza gönderilmesini sağlayabilirsiniz.

telegram yakın zamanda popüler olan bir uygulama olmaya başladığı için bu örnek telegram ile hazırlanmıştır. “/tool fetch ” komutundan sonraki ilgili url ‘yi sms api url si olarak değiştirirseniz aynı şekilde bilgiler tarafınıza sms olarak ulaşacaktır.

telebotID ve TeleChatID oluşturma ile ilgili makalemize
http://bilgi.wi.com.tr/telegram-bot-id-chat-id-olusturma/ ulaşabilirsiniz.

:global HAT1;
:global HAT2;
:global HAT3;
:local TELEBOTID;
:local TELECHATID;
:local HAT1YENIIP [/ip address get [find interface="HAT-1-TELEKOM"] address]; # dsl1 interface (pppoe client )ismi bu şekilde olmalıdır .
:local HAT2YENIIP [/ip address get [find interface="HAT-2-TELEKOM"] address]; # dsl2 interface (pppoe client )ismi bu şekilde olmalıdır .
:local HAT3YENIIP [/ip address get [find interface="HAT-3-TELEKOM"] address]; # dsl3 interface (pppoe client )ismi bu şekilde olmalıdır .


:if ($HAT1YENIIP != $HAT1) do={ # eger HAT1YENIIP ip , HAT1 ip den farklı ise ( mevcut IP 'den bunu haberdar etmek için koşulları başlat ) 
:put "ip address $HAT1 changed to $HAT1YENIIP";  # consloe'a log olarak yazıyoruz  Zorunlu değil 
:set HAT1 $HAT1YENIIP;  # global değişkende HAT1 'e yeni ip bilgisini yazıyoruz 
/tool fetch keep-result=no url="https://api.telegram.org/$TELEBOTID/sendMessage\?chat_id=$TELECHATID&text=HAT 1 IP DEGISTI $HAT1" ;  # fetch komutu ile telegram'a durumu gönderiyoruz. 
} 
:if ($HAT2YENIIP != $HAT2) do={   
:put "ip address $HAT2 changed to $HAT2YENIIP"; 
:set HAT2 $HAT2YENIIP;
/tool fetch keep-result=no  url="https://api.telegram.org/$TELEBOTID/sendMessage\?chat_id=TELECHATID&text=HAT 2 IP DEGISTI $HAT2" ;
} 
:if ($HAT5YENIIP != $HAT3) do={
:put "ip address $HAT3 changed to $HAT3YENIIP"; 
:set HAT3 $HAT3YENIIP;
/tool fetch keep-result=no url="https://api.telegram.org/$TELEBOTID/sendMessage\?chat_id=TELECHATID&text=HAT 3 IP DEGISTI $HAT3" ;

Kaynak : YAKANET ELK.HAB.HİZ.LTD.ŞTİ. / Muhammet bey .
Açıklama & Düzenleme : Wi.com.tr

By | 2017-05-30T10:10:56+00:00 30 Mayıs, 2017|Mikrotik WAN ip değişirse telegram ile haber gelsin. için yorumlar kapalı

About the Author: