0 850 650 0 500|teknik@wi.com.tr

Solar sistemde mikrotik voltaj bilgisi telegram ile gönderme

Bu senaryomuzda lokasyondaki routeros cihazlarının akü / solar sistem ile çalıştığını varsayıyoruz.
ve bu yapıda solar sistemdeki voltaj geriliminin 22 volt’un altına düştüğü durumda ( isterseniz bu değeri değiştirebilirsiniz ) . bu değerlerin durumuna göre tarafınıza enerji bilgisini veya eğer enerji bilgisi geri geldiyse yada yeterli şarj seviyesinde ise tekrar tarafınıza bilgi verilmesini sağlayabileceğiniz basit bir RouterOS script hazırlanmıştır.

telebotID ve TeleChatID oluşturma ile ilgili makalemize
http://bilgi.wi.com.tr/telegram-bot-id-chat-id-olusturma/ ulaşabilirsiniz.

:global SONDEGER;
:local MESAJ " ISTASYON ELEKTRIK GITTI"
:local VOLT  [/system health get voltage]
:local TARIH [/system clock get date] 
:local SAAT [/system clock get time] 
:local ISTASYON [/system identity get name]
:local TELEBOTID "Telegram Bot ID";
:local TELECHATID "Telegram Chat ID";
:local ESIK "22";  # solar sistem voltaj değerine göre uygun değeri yazınız 

:if ($VOLT<$ESIK) do={
/tool fetch keep-result=no url="https://api.telegram.org/$TELEBOTID/sendMessage\?chat_id=$TELECHATID&text=$ISTASYON $MESAJ -AKU VOLTAJI $VOLT - $TARIH $SAAT ";
:set SONDEGER $VOLT;
 }
:if ($SONDEGER>$ESIK) do={
/tool fetch keep-result=no url="https://api.telegram.org/$TELEBOTID/sendMessage\?chat_id=$TELECHATID&text=$ISTASYON $MESAJ -AKU VOLTAJI $VOLT - $TARIH $SAAT ";
:set SONDEGER 0;
}

kaynak : YAKANET ELK.HAB.HİZ.LTD.ŞTİ. / Muhammet bey .
Açıklama & Geliştirme : Wi.com.tr

By | 2017-05-30T10:09:55+00:00 30 Mayıs, 2017|Solar sistemde mikrotik voltaj bilgisi telegram ile gönderme için yorumlar kapalı

About the Author: