Layer 2 Tunneling Protocol ( L2TP )

İnternete çıkabildiğiniz ve firewall’dan l2tp için gerekli olan UDP 500 ve UDP 4500 portları engellenmediyse her networkten erişim sağlayabileceğiniz
bir protokoldür. Özellikle IOS işlem sistemli cihazlarda PPTP VPN desteği kaldırıldıktan sonra kullanıcılar için daha çok tercih edilmeye başlamıştır.
Windows , IOS ve Android ile desteği mevcuttur. Client olarak bu cihazlardan bağlantı sağlayabilirsiniz.
Kullanıcı adı , şifre ve pre-shared key bilgileri gereken vpn türüdür. VPN sağlayıcınız sizin için bu bilgileri oluşturup tarafınıza sunacaktır.

Mikrotik RouterOS destekli cihazlarda L2TP VPN kurulumları için;

Mikrotik cihazınızın öncelikle internete çıkıyor olması gerekmektedir.
Hızlı bir şekilde Mikrotik cihazınızı modem üzerinden aşağıdaki şekilde internete çıkarabilirsiniz.

/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1

*Mikrotik WAN bacağınızı Bridge veya Dmz olarak ayarlamanız daha sağlıklı olacaktır.

VPN bağlantısı gerçekleştiğinde Mikrotik’e tanımlı bir ip grubumuz olması gerekmektedir.
İç ağ ile karışmasını istemiyorsak yeni bir ip pool oluşturabiliriz.

/ip pool
add name=L2TP_VPN_POOL ranges=10.20.30.50-10.20.30.99

Vpn ip bloğumuzu belirledikten sonra bu adrese src-nat tanımlayarak dışarı çıkışta ( local ip kullanımı için ) masq olarak tanımlıyoruz.
Bunun için aşağıdaki kuralı girmemiz gerekmektedir.

/ip firewall nat
add action=masquerade chain=srcnat src-address=10.20.30.0/24
 

*L2TP vpn’in PPTP vpn’e göre avantajlarından bir tanesi şifreleme türüdür.
Bu şifrelemeyle alakalı dikkat etmemiz gereken bir nokta var.
Eğerki vpn bağlantımızı iki Router arasında gerçekleştirecek isek PPP menüsünde ki L2TP Secrets
bölümünden Public ip ve buna bağlı şifreleme oluşturabiliriz.
Eğerki isteğimiz Windows, Android veya IOS gibi makinelerden bağlantı sağlamak ise PPP/L2TP Server bölümünde
IPsec Secret girmemiz yeterli olacaktır.

Devam edecek olursak… PPP menüsüne ilerliyoruz. İlk olarak VPN bağlantımız için bir profil oluşturuyoruz. Oluşturduğumuz
profile isim verebiliriz. Daha sonra da Local Address ve Remote Address bilgilerini girebiliriz.
Local Address olarak gateway ip adresimizi girebiliriz. Remote Address olarak ip pool bölümünde oluşturduğumuz
pool’u seçebiliriz.

/ppp profile
add local-address=10.20.30.1 name=L2TP_PROFILE remote-address=L2TP_VPN_POOL

Şimdi L2tp Vpn’i aktif etmeye geldi sıra. PPP/Interface bölümüne gelip L2TP Server’a girmemiz gerekmektedir.
Burada aşağıdaki işlemleri gerçekleştirmeniz yeterli olacaktır.
Bu işlemleri anlatacak olursak önce Enabled seçeneğini işaretliyoruz. Profil bölümünü bizim oluşturduğumuz
profili giriyoruz. Son olarakta IPsec Secret bölümüne de güçlü bir şifre giriyoruz.Burada USE IPsec
kısmında “required”, “yes” ve “no” seçenekleri mevcut. Dilersek “no” seçeneğini seçip şifreleme olmadan ilerleyebiliriz.
“Required” seçeneği bize zorunluluk belirtir. Yani kesinlikle girmemiz gerekir. “Yes” seçeneği ise Client taraftan
bağlantı sağlayacak kişinin tercihe kalmış bir durumdur. Kısaca oluşturulan bu şifre client taraftan bağlantı yapıldığında istenecektir.
Son olarak aşağıda “One Session Per Host” seçeneği mevcuttur. Bir kullanıcı için bir bir bağlantıya izin vermek istiyorsanız seçeneği işaretleyebilirsiniz.

/interface l2tp-server server 
set default-profile=L2TP_PROFILE enabled=yes ipsec-secret=41_wicomtr_41 use-ipsec=required

VPN Server kurulumu tamamlandığına göre hangi kullanıcıları vpn bağlantısına dahil edeceksek bunlar için bir kullanıcı oluşturmamız gerekiyor.
PPP Secrets bölümüne ilerleyip +’ya bastıktan sonra gerekli bilgileri giriyoruz. Bunlar “name”, “password”, “Service” ve “Profile” bölümleridir.

/ppp secret
add name=wicomtr password=wicomtr profile=L2TP_PROFILE service=l2tp

Şimdi gelelim Client cihazlardan bağlantı yapmaya.

Windows 10 VPN Client Ayarları
Windows makinemizin AĞ ve İnternet Ayarları bölümüne giriyoruz. Bu bölümde VPN Ayarlarına giriyoruz ve ‘VPN Bağlantısı Ekle’
seçeneğine tıklıyoruz ve vpn client için bize verilen bilgileri giriyoruz.
VPN Sağlayıcı : Windows
Bağlantı Adı : Dilediğiniz bir isim girebilirsiniz
Sunucu Adı veya Adresi : Mikrotik Public Address
VPN Türü : Önceden Paylaşılan Anahtarlı L2TP/IPSec
Önceden Paylaştırılan Anahtar : 41_wicomtr_41
Oturum Açma Bilgisi Türü : Kullanıcı adı ve Parola
Kullanıcı Adı : wicomtr
Parola : wicomtr
Bilgilerini girip kaydet seçeneğine tıklıyoruz. Oluşturduğumuz vpn bağlantısına gelip bağlan dediğimizde
Mikrotik vpn bağlantımız gerçekleşmiş olacaktır.

Android VPN Client Ayarları
*Android cihazlarda Vpn ayarları her cihaz veya model için farklılık gösterebilmektedir.
Öncelikle Ayarlar bölümüne gidiyoruz.
Ayarlar bölümüne girdikten sonra burada bulunan “Daha Fazla..” seçeneğine tıklıyoruz veya arama bölümü varsa VPN yazıyoruz.
Daha fazla seçeneğine tıkladıktan sonra VPN seçeneğine tıklıyoruz ve “VPN Profili Ekle” seçeneğiyle tıklayıp bilgilerimizi gireceğimiz ekrana ilerliyoruz.
Mikrotik VPN Server’da oluşturduğumuz kullanıcı bilgilerini girebilmemiz için sırasıyla ilerliyoruz.
“name” kısmına dilediğimiz bir isim girerek “Type” kısmından da L2TP seçiyoruz.
Sonra ise ;
Server Address : Mikrotik Public Address
Ipsec Pre-shared key : IPsec Secret ( L2TP Server bölümünde verdiğiniz ip sec şifresi )
Kullanıcı adı : PPP/Secrets’da oluşturduğunuz kullanıcı adı
Parola : PPP/Secrets’da oluşturduğunuz şifre
Bilgilerini de girdiğimizi göre vpn bağlantısını sağlayabiliriz.

Iphone VPN Client Ayarları
Öncelikle telefonumuzdan “Ayarlar” bölümüne giriyoruz. Arama bölümüne “VPN” yazıp giriş sağlıyoruz.
Karşımıza gelen ekranda “VPN Konfigürasyonu Ekle” seçeneğine tıklıyoruz.
Bu bölümde ilk olarak Tür seçimi yapıyoruz. Vpn Türü olarak L2TP seçiyoruz ve gerekli yerleri dolduruyoruz.
Bu bilgileri de girdikten sonra “Bitti” seçeneğe tıkladığımızda son görsele ulaşıyoruz.
Burada da Durum yazan bölümde “bağlı değil” kısmını sağa sola çektiğimizde bağlı, bağlı değil şeklinde açıp kapayabiliriz.
Açıklama : Vpn bağlantısının ismi olacaktır. Dilediğimiz ismi verebiliriz.
Sunucu : Mikrotik Public Address
Hesap : PPP/Secrets’da oluşturduğunuz kullanıcı adı
Parola : PPP/Secrets’da oluşturduğunuz şifre
Sır : IPsec Secret ( L2TP Server bölümünde verdiğiniz ip sec şifresi )

Teşekkürler..