Point to Point Tunneling Protocol (PPTP)

VPN sağlayıcınız tarafından verilen sadece kullanıcı adı ve şifre ile bağlantı yapmanızı sağlayan vpn türüdür.
Client olarak bağlanabilmeniz için kullandığınız makinenin bunu desteklemesi gerekmektedir.
Windows işletim sistemli cihazlar PPTP VPN’i otomatik destekler. Firewall&Router’lar ile de client olarak
bağlantı gerçekleştirip işlemlerinizi tamamlayabilirsiniz.

Mikrotik RouterOS destekli cihazlarda PPTP VPN kurulumları için;

Mikrotik GW olarak kullanacağınız cihazın öncelikle internete çıkıyor olması gerekmektedir.
Hızlı bir şekilde arka tarafta bağlı bulunduğu modem üzerinden aşağıdaki şekilde internete çıkarabilirsiniz.

/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1

*Mikrotik Wan bacağınızı Bridge veya Dmz olarak ayarlamanız daha uygun olacaktır.

VPN bağlanısı gerçekleştiğinde Mikrotik’e tanımlı bir ip grubumuz olması gerekmektedir.
İç ağ ile karışmasını istemiyorsak yeni bir ip pool oluşturabiliriz.

/ip pool add name=PPTP_VPN_POOL ranges=10.20.30.2-10.20.30.40

Vpn ip bloğumuzu belirledikten sonra bu adrese src-nat tanımlayarak dışarı çıkışta ( local ip kullanımı için ) masq olarak tanımlıyoruz.
İp Firewall Nat bölümüne ilerleyip aşağıda ki işlemi yapmamız gerekmektedir.

/ip firewall nat
add action=masquerade chain=srcnat src-address=10.20.30.0/24

VPN için gerekli temel görevlerimizi yerine getirdikten sonra VPN SERVER kurulumunu tamamlamak için
PPP menüsüne ilerliyoruz. Öncelikle bu menüde bulunan PROFILE bölümüne gidip VPN yapımız için bir
profile oluşturmamız gerekmektedir. Bu kısımda birden fazla VPN Server kullanılacak ise porifilimize
bir isim vermemiz daha sağlıklı olacaktır. Profil ismini verdikten sonra hemen altında bulunan
Local Address ve Remote Address bölümlerini vpn için belirlediğimiz
ip bilgilerine göre vermemiz gerekmektedir. Local Address bizim gateway ip adresimiz olabilir.
Remote Address ise bizim ip bloğumuz olabilir.

/ppp profile
add local-address=10.20.30.1 name=PPTP_PROFILE remote-address=PPTP_VPN_POOL

Şimdi de Vpn Server’ı aktif etmemiz gerekiyor. PPP/Interface bölümüne gelip PPTP SERVER’a
tıklayıp “enabled” seçeneğini işaretlememiz gerekmektedir. Ayrıca PROFILE olarak da az önce oluşturduğumuz
profili seçmemiz gerekmektedir. Bu sayede bizim oluşturduğumuz profilde, bizim belirlediğimiz ip bilgileriyle ilerlemiş oluyoruz.

/interface pptp-server server
set default-profile=PPTP_PROFILE enabled=yes

Son olarak client olarak bağlanmasını istediğimiz kullanıcıların bilgilerini oluşturmak kaldı.
PPP Secrets bölümüne geldiğimizde “name”, “password”, “Service”, “Profile” bilgilerini girmemiz gerekiyor.
*Oluşturulan her kullanıcının ip adresini belirlemek istiyorsanız bu bölümde bulunan local&remote bilgileri
doldurabilir. Örn: Local Address : 10.20.30.1 Remote Address : 10.20.30.2 vb. şeklinde.

/ppp secret
add name=wicomtr password=wicomtr profile=PPTP_PROFILE service=pptp

Şimdi gidip remote windows bilgisayardan vpn bağlantımızı adım adım gerçekleştirelim.

Windows 10 VPN Client Ayarları

Windows makinemizin AĞ ve İnternet Ayarları bölümüne giriyoruz. Bu bölümde VPN Ayarlarına giriyoruz ve ‘VPN Bağlantısı Ekle’
seçeneğine tıklıyoruz ve vpn client için bize verilen bilgileri giriyoruz.
VPN Sağlayıcı : Windows
Bağlantı Adı : Dilediğiniz bir isim girebilirsiniz
Sunucu Adı veya Adresi : Mikrotik Public Address
VPN Türü : PPTP
Oturum Açma Bilgisi Türü : Kullanıcı adı ve Parola
Kullanıcı Adı : wicomtr
Parola : wicomtr
Bilgilerini girip kaydet seçeneğine tıklıyoruz. Oluşturduğumuz vpn bağlantısına gelip bağlan dediğimizde
Mikrotik vpn bağlantımız gerçekleşmiş olacaktır..