Mikrotik LTE/4G Bütünleşik model ürünlerinde yapılandırma nasıl gerçekleştirilir.

Mikrotik LTE 4G destekli modelleri :

Bu ürünler içerisinde bütünleşik olarak LTE / 4G Modem kartları bulunmaktadır. bu kartların yazılım güncellemeleri RouterOS güncellemesinden farklı olarak gerçekleştirilmektedir.

Bu işlemi gerçekleştirmek için aşağıdaki makaleyi incelemeniz gerekmektedir.


LTE Cihaz Yapılandırma ( 6.41 ve üzeri )
LTE cihazların çalışabilmesi için APN bilgisine ihtiyac vardır .varsayılan olarak turkiyede internet yada mbs olarak operatörler kullanmaktadır. ( bu bilgili operatörünüzden alınız )

/interface lte apn add profile=internet apn=internet authentication=none

LTE modemimize yeni oluşturduğumuz apn profilini tanımlıyoruz.

/interface lte set [find] apn-profiles=internet

LTE modeminin bağlantı durumunu takip etmek için. :

/interface lte print 
Flags: X - disabled, R - running 
 0  R name="lte1" mtu=1500 mac-address=AA:AA:AA:AA:AA:AA 

RouterOS versiyon 6.41 versiyonundan sonra LTE cihazları için otomatik olarak DHCP Client oluşmaktadır. Ayrıca LTE interface için DHCP client oluşmuyor ise aşağıdaki komut ile gerçekleştirebilirsiniz.

/ip dhcp-client
add default-route-distance=2 disabled=no interface=lte1

LTE Cihazından internete çıkış için masquerade gerekli

/ip firewall nat
add action=masquerade chain=srcnat out-interface=lte1

LTE Cihazının bağlantı durumu ile ilgili bilgileri görüntülemek için.

[[email protected]] > /interface lte info lte1 once 
status: call in progress
pin-status: no password required
functionality: full
manufacturer: Huawei Technologies Co., Ltd.
model: ME909u-521
revision: 12.631.07.01.00
current-operator: vodafone TR
current-cellid: 44436007
access-technology: Evolved 3G (LTE)
signal-strengh: -79 dBm
frame-error-rate: n/a
earfcn: n/a
imei: 860461024123456
imsi: 234012555034981
uicc: n/a
rssi: -79dBm
rsrp: -109dBm
rsrq: -13dB
sinr: -1dB

Örnek LTE bağlantısını doğrudan alt network ‘e yönlendirmek gerektiğini düşünelim
bu durumda Passthrough özelliğini kullanacağız.

[[email protected]] > /interface lte apn add apn=internet passthrough-interface=ether1
[[email protected]] > /interface lte set lte1 apn-profiles=internet

bunu farklı olarak 2 interface için tanımlamamızgerektiğini düşünelim . 1. port down olursa 2. port devreye girsin.
bu durumda bu model sayesinde interface ‘ler 1 yada 2. apn ‘ı kulanarak 1. yada 2. interface ‘den çıkış gerçekleştirebilir.

[[email protected]] > /interface lte apn add apn=apn1 passthrough-interface=ether1
[[email protected]] > /interface lte apn add apn=apn2 passthrough-interface=ether2
[[email protected]] > /interface lte set lte1 apn-profiles=apn1,apn2

AT Komutları ile bilgi alma

LTE Interface’ın Imei bilgisini öğrenmek için

[[email protected]] > /interface lte at-chat lte1 input="AT*mrd_imei\?"                         
  output: *MRD_IMEI:356159060388208

OK

komutu kullanılabilir .
Modem Frimware guncelleme işlemi .
Cihazın LTE Frimware Kontrol edilmeli .

/interface lte info lte1 once

R11e-LTE version (“MikroTik_CP_2.160.000_v006”) olması gerekli .
Modemi frimware Update mod’a alıyoruz.

/interface lte at-chat lte1 input="at+mififlag=1"

Cihazın frimware ‘ı mikrotik’in sitesinden download yapmasını bekliyoruz ( ~5mb dosya 3-4 dk sürebilir )

/interface lte at-chat lte1 input="at+func=18,2,\"http://mt.lv/ltefirmware.bin\""

Download durumunu görüntülemek için :

/interface lte at-chat lte1 input="AT+CHECKATUPGRADE"

(Not : Bu download işlemini LTE modem üzerinden gerçekleştirmektedir bu nedenle LTE cihazı 3G/4G networkune bağlı olmalıdır. )

Güncelleme tamamlandığında aşağıdaki cıktıyı görmeniz gerekiyor .

+CHECKATUPGRADE:0x1,100

Güncelleme tamamlandıktan sonra LTE modem’i resetliyoruz.

/interface lte at-chat lte1 input="at+reset"

resetleme işlemi sonrasında LTE interface’i 1-2dk kaybolup geri gelecektir. sonrasında sorgulama yaparsanız .

/interface lte info lte1 once

R11e-LTE version (“MikroTik_CP_2.160.000_v008”) olarak versiyonun güncellendiğini görebilirsiniz.

Bu işlem yeni versiyonlarda doğrudan routeros upgrade’i gibi kolay hale getirileceğini paylaşmak isterim.

Not : bu işlem esnasında cihazın enerjisi kesilir yada internet bağlantısı düştüğü için güncellemeyi alamaz ise cihazınızın LTE modeminin bozulması ihtimali var .
bu durum ürünü garanti dışı bırakabilir . hiçbir şekilde sorumluluk kabul edilmez.