Mikrotik kendini otomatik olarak güncellemesini istiyorsanız bunu ayda 1 yapacak şekilde bir script hazırlayabiliriz.

bu scriptde interval olarak 30 gün belirleyip aşağıdaki komut dizisini içerisine ekleyip uyguluyor olacağız .

bu sayede cihaz belirli aralıklarla güncelleme kontrolü yapacak ve uygun gördüğü zaman güncelleme işlemini otomatik olarak gerçekleştirecektir.

öncelikle güncelleme scriptini çalıştıran bir zamanlayıcı ayarlıyoruz.

/system scheduler add interval=4w2d name=Auto_Update on-event="/system script run guncelle" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon 

zamanlayıcıyı hazırladık ve çalıştıracağı script ismini guncelle olarak belirledik .
şimdi script’in içeriğini düzenleyelim.

/system script
add dont-require-permissions=no name=guncelle owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":log info "update start"
/system package update
check-for-updates once
 :delay 1s;
 :if ( [get status] = "New version is available") do={ install }

bu işlem sonrasında artık cihazımız 4hafta 2 gün ( yaklaşık 30 günde bir güncelleme işlemini kontrol edip gerçekleştirecektir.

Komutu copy paste ile eklediğinizde eğer hata çıkıyor ise çok eski bir sürüm yada noktalama işaretleri ile ilgili problem yaşıyor olabilirsiniz.
el ile /system script menüsü içerisine girip “guncelle” isminde bir script oluşturup aşağıdaki komutu yapıştırmayı deneyiniz.

:log info "update start "
/system package update
check-for-updates once
:delay 1s;
:if ( [get status] = "New version is available") do={ install }

— Cıhazın internete erişebilir olması gerekmektedir.
test için —
/ping download.mikrotik.com
eğer test sonucu çıkmıyor ama cihaz ip tanımlı ise dns server bilgilerini kontrol ediniz.

teşekkürler.