WISP işi ile uğraşan arkadaşların genel ihtiyaçları arasında yer alan Client cihazlarının tanımlamaları ve daha sonraki ulaşım konusunda zorluk yaşamamak için Wifi ‘deki radyo ismini PPPoE kullanıcı adı ile otomatik hale getirilmesi gerekebilmektedir.

Bu gibi durumlar için ihtiyacınızı çözümlemek adına aşağıdaki script ile ihtiyaçlarınızı çözümleyebilirsiniz.

:global userset
:set $userset [/interface pppoe-client get pppoe-out1 user];
/system identity set name=$userset
/interface wireless set 0 radio-name=$userset

burada komutu anlatmak gerekir ise

:global userset ile genel olarak erişilebilir bir değişken tanımlıyoruz.
daha sonrasında
:set komutu ile birlikte $userset değişkeninin alacağı değer bilgisini pppoe client ‘in user bilgisi olarak çekiyoruz
daha sonra önce system identity sonra wireless kartı radyoname bilgisini $userset değişkenindeki bilgi ile güncellemesi için gerekli komutları gönderiyoruz.

ayrıca bu her cihaz açılışında çalışmasını istiyorsanız script dışında bir scheduler oluşturmak gerekmektedir.

aşağıdaki tam çıktıda önce bir script oluşturup yukarıdaki script’i tanımlıyor . sonrada scheduler ile kayıt giriyoruz.

bu işlemi komut dizisi olarak aşağıdaki komut ile hızlıca cihazınıza aktarabilirsiniz.

/system script
add dont-require-permissions=no name=wifi-isim-duzenle owner=admin policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":gl\
    obal userset\r\
    \n:set \$userset [/interface pppoe-client get pppoe-out1 user];\r\
    \n/system identity set name=\$userset\r\
    \n/interface wireless set 0 radio-name=\$userset\r\
    \n"


/system scheduler
add name=wifi-isim-kontrol on-event="/system script run wifi-isim-duzenle" policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-time=startup