Switch yada Router’ınızın portlarına bağlı cihazların eğer port seviyeleri ( 10Mbps / 100Mbps 1G yada 10G bağlantı seviyesi herhangi bir şekilde değişiyor ise bu durumu takip edecek bir uygulamaya ihtiyaç duyabillirsiniz. bu tarafta telegram ile basit bir uygulama geliştirdik . ethernet’in durumunu kontrol ediyor ve eğer belirediğiniz değerin dışında bir değere sahip oluyorsa size telegram ile mesaj gönderiyor.

Örnek Senaryo :

Ether1 portuna takılı olan cihazımız 1Gbps lik bir bağlantıya sahip , fakat bir şekilde portun 100Mbps yada 10Mpbs olduğunu düşünüyorsunuz .bunu takip etmek istiyorsunuz.
bu tarafta aşağıdaki uygulama örneğini kullanarak portun durumunu kontrol edip telegram ile haberdar olabiliriz.

telebotID ve TeleChatID oluşturma ile ilgili makalemize http://bilgi.wi.com.tr/telegram-bot-id-chat-id-olusturma/ ulaşabilirsiniz.
Video Anlatımımıza : https://www.youtube.com/watch?v=o1euS92XITE bu link’den ulaşabilirsiniz.

:local TELEBOTID bot750189240:AAFGa629deuCR_ysC7BxxxxfaCNm3_S4wCc
:local TELECHATID 2222222222
:local MESAJ " ISTASYON PORT DEGISTI"
:local VOLT  [/system health get voltage]
:local TARIH [/system clock get date]
:local SAAT [/system clock get time]
:local ISTASYON [/system identity get name]
:local INTER "ether1"
:local OLMALI "1Gbps"
:local INTERVALUE [/interface ethernet get $INTER value-name=speed]
:if ($INTERVALUE!=$OLMALI) do={ 
:local gonder "$ISTASYON $MESAJ $INTER $OLMALI olmali fakat $INTERVALUE kontrol edin  $TARIH $SAAT "
/tool fetch keep-result=no url="https://api.telegram.org/$TELEBOTID/sendMessage\?chat_id=$TELECHATID&text=$gonder"; }

Artık yapmanız gereken yukarıdaki alanları ihtiyaçlarınıza göre doldurmak ;

:local OLMALI “100Mbps” bu örnek olarak 100Mbps , 1Gbps , 10Mbps , 10Gbps olarak portun değerinin ne olmasını istediğinizi yazıyorsunuz. buradaki değerin doğru ve boşluksuz yazılması gerekmektedir.
:local INTER “ether1” bu alana hangi ethernet interface’inizi kontrol etmek istediğinizi yazıyorsunuz . Ether1,2,3 veya sfp1 gibi .

TELEBOTID ve TELECHATID alanlarına yukarıdaki video’da yer alan anlatımlardan faydalanarak bir bot ve chatid oluşturup kullanabilirsiniz.

Mikrotik Cihazinizin ismini /system identity bölümünden güncel tutmanız cihazın isim bilgisinin size doğru gelmesini sağlayacaktır.

işlem bu kadar..

Videomuzu beğenmeyi ve kanalımıza abone olmayı unutmayınız.