Müşterilerimizin bağlı bulunduğu AP ‘deki sinyal seviyelerini takip edip müşteriden önce işlem gerçekleştirmek, ve haberdar olup sorunu incelemek gerekebilir .

bu gibi durumlarda sinyal seviyesini kontrol edip telegram ile kendinize bilgi gönderilmesini sağlayabilirsiniz.

bu işlem için aşağıdaki kodu scheduler’e 3-5dk lık görev olarak tanımlayabilirsiniz.

telebotID ve TeleChatID oluşturma ile ilgili makalemize http://bilgi.wi.com.tr/telegram-bot-id-chat-id-olusturma/ ulaşabilirsiniz.
Video Anlatımımıza : https://www.youtube.com/watch?v=o1euS92XITE bu link’den ulaşabilirsiniz.

:local TELEBOTID xxxxxx
:local  TELECHATID xxxxxx
:local seviye -60;
:local sub1 ([/system identity get name]);
:local signal;
:local radio;
:foreach i in=[ /int wir reg find] do={ 
  :set signal [int wir reg get $i signal-strength];
  :set signal [ :pick $signal 0 [:find $signal "dBm"]]
  :set radio [/interface wireless registration-table get $i radio-name]
  :if ($signal < $seviye) do={
      /tool fetch url="https://api.telegram.org/$TELEBOTID/sendMessage\?chat_id=$TELECHATID&text=$sub1 anteninde $radio abonesinin sinyali bozulmus.Sinyal degeri $signal" 
  }
}

TELEBOTID ve TELECHATID alanlarına yukarıdaki video’da yer alan anlatımlardan faydalanarak bir bot ve chatid oluşturup kullanabilirsiniz.

Mikrotik Cihazinizin ismini /system identity bölümünden güncel tutmanız cihazın isim bilgisinin size doğru gelmesini sağlayacaktır.

işlem bu kadar..

Videomuzu beğenmeyi ve kanalımıza abone olmayı unutmayınız.

Kaynak : www.durunet.com.tr Ceyhun Çalışkan ‘a paylaşımından dolayı teşekkür ederiz.